Dodge Dakota ForumDodge Dakota PhotosDodgeDakota.net Membership
  Forums   Forum Tools
08:40:11 - 10/24/2014

Dealer, TSB's and Recalls
FromMessage
LVDAK
Dodge Dakota
JOIN HERE


8/10/2006
00:11:22

Subject: BRAKE LIGHT ON
IP: Logged

Message:
i replaced the rear speed abs senson like u guys said and it did help thank you...but the abs light and brake light still come on when i go over 65 mph? what could be wrong here?? any thoughts would be appreciated..



Andrew
Dodge Dakota
JOIN HERE
 Email

8/24/2006
13:01:00

BRAKE LIGHT ON
IP: Logged

Message:
I read through this last night after a google search, and noticed that no one thought to check the new sensor before installing it. I just picked one up from a local dealer part # 1-56028187AE.
It shows 1.6 ohms (uninstalled). I haven't checked my original sensor yet, but noticed most people with defective ones were 0 ohms. Hope it helps.



Afromankam
Dodge Dakota
JOIN HERE
 Email

9/04/2006
03:35:48

BRAKE LIGHT ON
IP: Logged

Message:
When I had that problem (ABS & Brake Lights) It was a sign that one if not both of the front wheel bearings were going out.



ohhbob
Dodge Dakota
JOIN HERE
 Email

9/04/2006
12:58:30

BRAKE LIGHT ON
IP: Logged

Message:
Wow...seems like this is a real problem on Dakotas. Here's my version...we inherited this truck and noticed both the speedo & odometer didn't work along with the check engine, abs & parking brake light being on. In preparation for selling the truck, I took it for and failed the emissions test. Code P0500 - bad speed sensor. Had that replaced but it didn't fix it. The shop suggested having the dealer clear the codes. Borrowed a code reader from a buddy and that wouldn't clear them either. Currently have the battery disconnected with my fingers crossed. Any other similar anamolies???



daddio
Dodge Dakota
JOIN HERE
 Email

9/07/2006
14:23:50

BRAKE LIGHT ON
IP: Logged

Message:
which "speed sensor" did you change? the RWSS(rear wheel speed sensor), located in the rear diff. is probably the culprit.



Joe Navy
Dodge Dakota
JOIN HERE
 Email

9/11/2006
18:29:14

SPEEDOMETER DOESN'T WORK
IP: Logged

Message:
My ABS light, brake light and check engine light came on and my speedometer quit working. I replaced both speed sensors but my speedometer still doesn't work. I drove it over 40 mph and it still doesn't register. I also disconnected the battery cable for about 5 minutes, but no luck. Any suggestions for my problem. Thanks in advance!



Andrew
Dodge Dakota
JOIN HERE
 Email

9/11/2006
19:30:57

BRAKE LIGHT ON
IP: Logged

Message:
The rear sensor should read 1.6 ohms, and I believe the front sensor was less than 1 ohm, tho I didn't write it down and couldn't tell you exactly. It is possible you have a bad sensor, but more likely you have a short in your wiring as I've noticed some others mention.

I replaced the rear when ABS and Brake Light came on, then in less than a week the check engine light came on, shifted erratic, and had poor power off the line. I replaced the tranny sensor (thanks to whoever mentioned raising the rear up so I didn't get a ATF shower) and had to unhook the negative for a minute to clear the code. So far everything is working fine.




captain
Dodge Dakota
JOIN HERE
 Email

10/20/2006
09:02:42

BRAKE LIGHT ON
IP: Logged

Message:
abs and brake lights still come on intermittently even after the sensor has been changed. i scanned the vehicle and got a code for abs main relay open . does anyone know where this relay might be......ken



Andrew
Dodge Dakota
JOIN HERE


10/20/2006
09:43:26

BRAKE LIGHT ON
IP: Logged

Message:
I'm pretty sure that the main relay would be the solenoid looking block on the fenderwell, right beside the master cylinder. It looks like the ABS module is right beside it - and if I'm not mistaken, the warrenty is different on that component.



al
Dodge Dakota
JOIN HERE


12/15/2006
19:16:56

BRAKE LIGHT ON
IP: Logged

Message:
My ABS and brake lights are on continuously on the instrument pane.
My brakes work fine.
BUT.....my brake lights themselves in the back of the truck dont work at all.

Is this more likely to be a brake petal sensor that is bad or the pressure sensor in the differential as described above. Or another problem?

al



BobH
Dodge Dakota
JOIN HERE
 Email

5/26/2007
02:44:12

BRAKE LIGHT ON
IP: Logged

Message:
Similar but not identical problem.

2000 Ram 1500 2wd Quadcab since new, with 71000K on the
ODO and the 'standard' superchips program and 30" wheels
programmed in for the past year.

Everything was running great. Went out to go to a meeting this
evening and the ABS and Brake light came on. However, not
having the benefit of this thread, I popped the hood and
discovered my brake fluid reservoir EMPTY!!! DOH! i know i had
checked that within the past 3 months and it was full. So, there's
a problem that needs solving regardless. However, after i filled
the reservoir, the ABS and Brake lights are still illuminated.

Is it possible that i've A) damage dthe brake light switch (sounds
unlikely)? B) damaged the ABS sensor in the diff? C) gotten air in
the lines and they need to be bled? D) something else?

If the answer is C: needs to be bled, is it true i need some
special tool to bleed ABS brakes? Or can i just do it old school
with a mason jar of brake fluid, some plastic tubing and a
helper?

any ideas would be appreciated. I'm not looking forward to a
$200 diagnostic visit to the dealer.



TwoGuns
Dodge Dakota
JOIN HERE
 Email

6/16/2007
03:31:58

ABS Light On and Audible Tone
IP: Logged

Message:
Okay, I own a 2002 Dakota Sport, 4x4 with approx. 132,000 mi on a 4.7 litre motor.

Recently I took my truck into a electrical repair shop to address error code P0107: Low electrial output, MAP sensor. This was causing my motor to have "hiccups" when under a load (accelerating.) The MAP sensor was replaced ($95.00) but this failed to resolve the issue.

Secondly, the ding-a-ling technician, instead of test driving my vehicle thought it would be a good idea to "power brake" my vehicle instead to create a "load" condition. This action caused a new problem: the ABS light came on with a warning "bell" that sounds every three seconds.

Unlike other postings, my speedo and brakes work fine but I am still dealing with the original problem and now the ABS problem. The technician said he attemtped to clear the ABS problem, to no avail, by resetting the codes.

Any of you folks out there have any advice as to how I can resolve both of these problems before I spend some major $$$ taking it into a Dodge dealership?

Sincerely,

TwoGuns





Chip Lamb
Dodge Dakota
JOIN HERE
 Email

6/25/2007
10:33:54

BRAKE LIGHT ON
IP: Logged

Message:
Just one more for the record, 99 Ram 2500, turned it on cold yesterday morning, ABS/Brake lights on, no speedo. Rear diff sensor had 13,000,000 ohms resistance. New sensor would not give me stable reading, had momentary blips with DVOM. Noted also wires chafing at driver's side sway bar link in rear.

Taped them up for now and tied them and one e-brake cable to stanchion holding other e-brake cable under vehicle to keep them reasonably clear of swaybar link. Only the white/black tracer wire was chafed through, this may have caused the sensor failure.

Thanks for saving me far more than the $38.06 at Dodge this morning, invaluable info.



JKC INC
Dodge Dakota
JOIN HERE
 Email

6/26/2007
18:22:12

BRAKE LIGHT ON
IP: Logged

Message:
98 ram 2500 4x4 cummins... Brake and ABS on no check engine light, speedo works fine, but sometimes jumps around...very random... Cruise control works except for when speedo decides to act up,and no green cruise control light. Also SOMETIMES tranny acts up where it kicks out of overdrive(I dont know if anyone has ever done this but tap on the brakes while your in OD and the tranny will kick you out of OD)thats what it feels like...So im guessing all of these things are related to the same thing, electrical, and faulty :) Im gonna start with the cheap sensor and check all the wires. This all started happening after driving on a bumpy dirt road.



Justin Dunlap
Dodge Dakota
JOIN HERE
 Email

7/07/2007
17:03:47

BRAKE LIGHT ON
IP: Logged

Message:
Our 99 Durango just started to have the same problems listed here. ABS/brake light and intermittent speedo. Yesterday the check engine light came on and the speedo is dead.

Thanks to the Internet and this forum I am going to be able to fix this problem for about $80 (both sensors) and an hour in the garage.



CBG
Dodge Dakota
JOIN HERE
 Email

7/10/2007
14:36:51

BRAKE LIGHT ON
IP: Logged

Message:
I also had the same problem in my 99 Dakota 4x4. Same symptoms, ABS light, Brake light, no Speedo.

Replaced the rear wheel speed sensor on the differential...fixed everything!



DakTruk
Dodge Dakota
JOIN HERE
 Email

8/14/2007
14:08:25

BRAKE LIGHT ON
IP: Logged

Message:
I have a 99' dakota 5.2 v8, ABS and Brake light are on, alot of fluid is leaking out the bottom. Just a bad hose? thanks



spudlink
Dodge Dakota
JOIN HERE
 Email

9/05/2007
00:43:27

ABS/Brake Light On
IP: Logged

Message:
I have a problem with my 2001 Ram 1500 2wd 5.9 where it switches the abs/brake lights on few seconds after hitting 65 mph. The brakes do not work properly, the pedal feels as if there is nothing there for part way down then it will just lock up the wheels. Was told it may be the main abs unit.
Thanks, Micah



steven hart
Dodge Dakota
JOIN HERE
 Email

10/13/2007
22:44:00

BRAKE LIGHT ON
IP: Logged

Message:
I have a similar problem with a 98 dodge ram 2500 3/4 ton 5.9 litre diesel 4wd p/u. abs light on, red "brake" light on.
hydraulic control unit (hcu) runs continuously even with the key off. speedo o.k., odometer o.k. cruise o.k. Auto door locks o.k. So I am confident the vehicle speed sensor on the tranny is good and I just did the rwal sensor on the differential this afternoon(26.99 at NAPA).left the batteries disconnected while I did the sensor swap hoping to clear the fault codes. No joy. abs and brake light on the dash are still lit and the hcu still runs. I had to pull the fuse at the power distribution center to turn it off. I assume the hcu motor has a relay associated with it,is it internal or external? Does anyone have a descent electrical schematic of the system? Haynes has been no help here.
thanks in advance
shart4legged



JB
Dodge Dakota
JOIN HERE


10/16/2007
23:37:04

BRAKE LIGHT / ABS LIGHT/ ENGINE LIGHT ON
IP: Logged

Message:
Best info I've found yet!

2000 SLT 5.9L 2WD

Brake light & ABS came on together first. Then a few months later the speedo is a no-go until 35-40 mph. Then came the check engine light. Sound familiar?

BUT... Has any else experienced shifting issues with their auto tranny's? Mine will exceed normal rpm before shifting into second. I can let my foot of the accelerator and it will shift OK, but it's aggravating. Curious if this could be related to the rear diff sensor as well.

Also, is there ANYWHERE on the web I can see a diagram od the sensor's location on the rear diff?

Thank you!!!



  <<Previous Page P 9 Next Page>>


 



Home | Forums | Members | Pictures | Contact Us

This site is in no way affiliated with Chrysler or any of its subsidiaries.