Dodge Dakota ForumDodge Dakota PhotosDodgeDakota.net Membership
  Forums   Forum Tools
18:28:05 - 06/06/2020

V8 Dakotas
FromMessage
brad
Dodge Dakota
JOIN HERE
 Email

8/19/2005
22:59:38

Subject: clutch install problems
IP: Logged

Message:
I just did the 3.9 to 5.2 engine swap and i cant get my clutch to get pressure to disengage. We installed a new clutch in it during the engine swap. Since the clutch wasn't getting any pressure we installed a new slave clyinder. Still we couldnt get anything, so we installed a new master clyinder and a new line going to the slave clyinder, and i still cant get anything.

when we installed the slave clyinder the stock molded line broke so we used fuel line and clamps for the new one. Could this have anything to do with it not getting any pressure.

The slave clyinder has some pressure but when we installed it all the clutch pedal has little to no pressure behind it and we pumped the hell out of it.

Any suggestions will be appreciated.




Me
Dodge Dakota
JOIN HERE


8/20/2005
00:51:10

RE: clutch install problems
IP: Logged

Message:
Your going to have to get a new clutch line. Fuel line will not work. The clutch line is like a brake line and uses hydraulic press, so everytime you push the pedal in all thats happening is that fuel line is expanding.. Thats why you're not getting enough pressure to release the clutch, the line just expands too much. Do yourself a favour and get the proper line ASP.



   P 1


Post a reply to this message:

Username Registration: Optional
All visitors are allowed to post messages


Name:
Email:
Notify me when I get a reply to my message:Yes  No

Icons:            

          

Subject:
Message:
 



Home | Forums | Members | Pictures | Contact Us

This site is in no way affiliated with Chrysler or any of its subsidiaries.