Dodge Dakota ForumDodge Dakota PhotosDodgeDakota.net Membership
  Forums   Forum Tools
21:23:37 - 08/28/2014

V8 Dakotas
FromMessage
Red 99 Dak R/
Dodge Dakota
JOIN HERE
 Email

7/16/2005
00:43:24

Subject: Tune Up
IP: Logged

Message:
My 99 Dakota has 70k Miles. I get an intermitent check engine light. When I checked the code at one of the Parts Stores, I got an error. The Dealer said it was the up stream O2 Sensor caused by an after market Exhaust. My thinking is that the plugs and wires are the originals and are worn enough to cause a bad O2/fuel sense. Oh, the check engine light comes on mostly when the engine is near idle. I plan to do a tuneup, and I was told to use the original OEM plugs, No Platnum or split fire plugs. I could use advice to what anyone else thinks.



rc
Dodge Dakota
JOIN HERE
 Email

7/19/2005
15:02:35

RE: Tune Up
IP: Logged

Message:
I recently change the spark plugs and oil on my 02 4.7 4x4. i pretty much stayed along the lines of what the factory recomends. I used champion spark plugs (cheaper and recomended)you want to stay within the recomended heat range. I have a flowmaster exhuast and havent had any problems with any sensors, this was put on back in NOV 04. Stay away from platinum and split fires...they heat up and platinum is a inert metal, stick with copper.



Trons
Dodge Dakota
JOIN HERE


7/20/2005
00:33:40

RE: Tune Up
IP: Logged

Message:
"Platinum is an inert metal."
True. That's what makes it such a good conductor.




skat dak
Dodge Dakota
JOIN HERE


7/27/2005
22:47:04

RE: Tune Up
IP: Logged

Message:
use factory tune up parts and replaced your upstream o2 sensor. depending on which motor you have you could have more then one in which case you should find out the faulty o2. your exhuast wont cause an o2 sensor fault unless of course your running with you exhuast manifolds un bolted from your cylinder heads.



Red 99 Dak R/
Dodge Dakota
JOIN HERE
 Email

7/28/2005
17:16:24

RE: Tune Up
IP: Logged

Message:
The problem is that the check engine light code comes up with nothing. The equipment shows ERROR. If it showed me a definite O2 Sensor code, it would have already been changed, but sometimes it takes 50 mile before it comes on, and then other times it takes 350 miles, and never has come on during accelaration.



Forseti
Dodge Dakota
JOIN HERE


7/28/2005
18:51:37

RE: Tune Up
IP: Logged

Message:
Sounds like the start of a CCD BUSS problem .....



Pacman
Dodge Dakota
JOIN HERE


7/29/2005
17:24:05

RE: Tune Up
IP: Logged

Message:
Funny how the dealer claims he knows what the problem is when the diagnostic won't even spit out a code. As far as the plug issue, I've heard too many issues with platinum plugs, but on the R/T. Mine just happens to be an R/T. A friend that's a mech at the dodge dealer said to stay with the champion plugs that were original.



Red 99 Dak R/
Dodge Dakota
JOIN HERE
 Email

7/29/2005
21:59:55

RE: Tune Up
IP: Logged

Message:
Forseti: What do you mean by CCD BUSS Problem?



   P 1


Post a reply to this message:

Username Registration: Optional
All visitors are allowed to post messages


Name:
Email:
Notify me when I get a reply to my message:Yes  No

Icons:            

          

Subject:
Message:
 



Home | Forums | Members | Pictures | Contact Us

This site is in no way affiliated with Chrysler or any of its subsidiaries.