Dodge Dakota ForumDodge Dakota PhotosDodgeDakota.net Membership
  Forums   Forum Tools
11:05:35 - 07/22/2014

V8 Dakotas
FromMessage
mcguire
Dodge Dakota
JOIN HERE
 Email

10/28/2003
04:32:51

Subject: fault code p0320
IP: Logged

Message:
i have a 2000 4.7L dodge dakota. when it gets warm the service engine light will come on and at about 2500 RMPs it will cut power (like a gov.) in any gear! my question is does this fault code describe the problem? has anyone ever had this problem.



pDak
Dodge Dakota
JOIN HERE
 Email

10/28/2003
08:54:34

RE: fault code p0320
IP: Logged

Message:
According to the code sheet that has been posted on this site a p0320 says "Crankshaft position sensor reference signal cannot be found while engine is cranking". Sounds like this could be your problem only it happens when you are running. I would look to see if something is interfearing with this sensor. Check around the crankshaft damper, I would look here first. May have a wire that the insulation has been nicked.

Pdak
2002 CC 4.7 Z-tube,tonneau and some other mods my wife doesn't need to know about



mcguire
Dodge Dakota
JOIN HERE
 Email

10/28/2003
10:34:53

RE: fault code p0320
IP: Logged

Message:
i looked all around the damper and found no wires. is it possable that it could be located on the back side near the flywheel? also i noticed that when this problem started it would cut power at exactly 2700 RMPs. now it does it at 2500 RPMs. i don't know if this has any relevants. all i know is this problem has me stumped! any help would be great!



skitter
Dodge Dakota
JOIN HERE


11/04/2003
03:25:31

RE: fault code p0320
IP: Logged

Message:
It may be a pcm problem. My pcm started having memory problems and the transmission started shifting weird. It also had a idle problem. When the dealership replaced the pcm, it all worked fine. The pcm reads off all these sensors and sometimes it forgets how. It's like it gets amnesia or something.



xxdak00269
Dodge Dakota
JOIN HERE
 Email

11/06/2003
10:23:48

RE: fault code p0320
IP: Logged

Message:
If you are looking for the crank sensor it is under the pasenger side rear freez plug. and im sure it is that sensor that is bad I do not know how many of the things that I have replaced, but I do know that code I have seen it to many times to forget it.


if ya got any more questions for me just
email me xxkendog269@aol.com



   P 1


Post a reply to this message:

Username Registration: Optional
All visitors are allowed to post messages


Name:
Email:
Notify me when I get a reply to my message:Yes  No

Icons:            

          

Subject:
Message:
 



Home | Forums | Members | Pictures | Contact Us

This site is in no way affiliated with Chrysler or any of its subsidiaries.