Dodge Dakota ForumDodge Dakota PhotosDodgeDakota.net Membership
  Forums   Forum Tools
13:04:30 - 07/24/2014

V6 Dakotas
FromMessage
Rick
Dodge Dakota
JOIN HERE
 Email

6/11/2005
12:25:24

Subject: Overdrive NOT Working
IP: Logged

Message:
I have a 95' 3.9 4x4 automatic and the OD is not working. I pulled the dash switch and disassembled. The push prong is good in the switch, the bulbs are good, the fuse is good, I have power. The plug in the tranny seems good and I have a newer computer. THE OVERDRIVE DOES'NT WORK! HELP!?



93dak4x4
Dodge Dakota
JOIN HERE
 Email

6/12/2005
20:08:16

RE: Overdrive NOT Working
IP: Logged

Message:
you really didnt leave us with anything to tell you. your overdrive unit might be fried. if the switch, fuse, and wiring are all good i dont know what to tell you, consult a technition...namely larry. id ask him before i ever trust those bastar ds at the dealership...

they wanted $441 for a cat con....
hahahaha 3" polished magnaflow $91 shipped



Dan M
Dodge Dakota
JOIN HERE
 Email

6/12/2005
22:30:04

RE: Overdrive NOT Working
IP: Logged

Message:
could be overdrive switch - checked continuity? or the overdrive solenoid.

Alldatadiy has some decent info on checking the solenoid. requires checking wiring/fuses.

I recommend you get a subscription.

- Dan M



Bob Lincoln
Dodge Dakota
JOIN HERE


6/12/2005
22:55:32

RE: Overdrive NOT Working
IP: Logged

Message:
O/D solenoid failed or loose from the valve body. Also can be anywhere in that electrical circuit, but most commonly seems to be the solenoid pack coming loose from the valve body. Drop pan, drain, tighten 3 screws, put pan on, refill, done.

If still N/G, make sure car is not overheating. It will not come on below coolant temp of 140F or above 260F.



jayb
Dodge Dakota
JOIN HERE
 Email

6/14/2005
06:59:25

RE: Overdrive NOT Working
IP: Logged

Message:
if it doesnt go into overdrive, then like someone said, the od unit could be fukked. but if its not, and we will assume it isnt, check this crap.
1. the switch, with a meter.
2. coolant sensor
3. tps
4. speed sensor
5. the engine has to be at a certain rpm to allow overdrive to work. so, if your tach doesnt work, id check that too.
6. check the wire connectors. dirty?
all that crap hasto work for overdrive to engage. i read that in the a518/a500 manual. and if all else fail, Sh!t, drop the pan and see if you find anything in it.



   P 1


Post a reply to this message:

Username Registration: Optional
All visitors are allowed to post messages


Name:
Email:
Notify me when I get a reply to my message:Yes  No

Icons:            

          

Subject:
Message:
 



Home | Forums | Members | Pictures | Contact Us

This site is in no way affiliated with Chrysler or any of its subsidiaries.