Dodge Dakota ForumDodge Dakota PhotosDodgeDakota.net Membership
  Forums   Forum Tools
09:37:15 - 06/24/2019

V6 Dakotas
FromMessage
DakotaJo
Dodge Dakota
JOIN HERE
 Email

11/22/2004
08:35:55

Subject: Oil Light
IP: Logged

Message:
My oil light came on today on my way to work. The presure gauge is showing no presure at all. The gauge did bounce up a bit when I hit a bumb, I think. I just swapped in another engine. I`m thinking that my buddy that did the swap used the same oil filter. Would that have anything to do with it? I just checked the oil 2 days ago and it was fine, still like new. If anyone has any ideas please let me know.

1989 v6 3.9, 4wd, 5-speed



vern
Dodge Dakota
JOIN HERE
 Email

11/22/2004
18:57:15

RE: Oil Light
IP: Logged

Message:
try checking the wire plug on the sending unit
[pass side,back beside dist]

you may need a new sending unit $20-25 this is pretty common



DakotaJo
Dodge Dakota
JOIN HERE
 Email

11/23/2004
07:36:38

RE: Oil Light
IP: Logged

Message:
Anyway of checking the sending unit to see if it is broken?



daddio
Dodge Dakota
JOIN HERE


11/23/2004
09:12:22

RE: Oil Light
IP: Logged

Message:
you could take out the sending unit and install a mechanical gage to check the oil pressure.



   P 1


Post a reply to this message:

Username Registration: Optional
All visitors are allowed to post messages


Name:
Email:
Notify me when I get a reply to my message:Yes  No

Icons:            

          

Subject:
Message:
 



Home | Forums | Members | Pictures | Contact Us

This site is in no way affiliated with Chrysler or any of its subsidiaries.