Dodge Dakota ForumDodge Dakota PhotosDodgeDakota.net Membership
  Forums   Forum Tools
16:12:36 - 08/30/2014

Dakota Performance
FromMessage
mcarthey
Dodge Dakota
JOIN HERE
 Email

9/22/2004
14:31:17

Subject: P0351 Ignition Coil A Primary/Secondary
IP: Logged

Message:
Hey all, I have code P0351 showing up and it is listed as : P0351 Ignition Coil A Primary/Secondary Circuit Malfunction.
Does this mean the coil could be bad, or maybe a bad connection to the coil? I see there are codes for ignition coils A-L. Twelve codes? I was thinking spark plugs, but... ? I'm not sure where to start looking for this.
I do have the MSD coil and 6A ignition. It's pretty new so I doubt it's bad but could it be causing this code to appear?
Ideas?
Thanks!
Mark



?
Dodge Dakota
JOIN HERE


9/22/2004
15:05:26

RE: P0351 Ignition Coil A Primary/Secondary
IP: Logged

Message:
Yes , that coil setup is giving you the code !

I saw somewhere a { special kit } for use with
those coils - for certain vehicles .
You might check with where you got the coil ?



Ken
Dodge Dakota
JOIN HERE


9/22/2004
15:18:49

RE: P0351 Ignition Coil A Primary/Secondary
IP: Logged

Message:
I've always had that code on my truck, even with stock ignition system, but it never tripped my MIL, but it is a code (as a warning?) that I always pull. Even after I upgraded to a 300+ Accel Ignition system. I just gave up on it.



mcarthey
Dodge Dakota
JOIN HERE
 Email

9/22/2004
19:21:14

RE: P0351 Ignition Coil A Primary/Secondary
IP: Logged

Message:
I talked to a tech at MSD and he said that I could fix it with MSD-8910. (This Tach Adapter will correct the operation of most voltage-triggered tachometers or fuel injection systems that do not run directly off the tach output of the MSD unit). The delay box is causing the spark to flash outside the pcm's expected window, thus throwing a fault code.
I'll purchase the harness. It's only $25. That should take care of it.
Thanks all,
Mark



Dakaty
GenIII
 User Profile


9/22/2004
19:29:55

RE: P0351 Ignition Coil A Primary/Secondary
IP: Logged

Message:
That code is very common with the MSD ignition. I had the same problem that went away when the tach adapter was installed.

14.63 @ 91.8

   P 1


Post a reply to this message:

Username Registration: Optional
All visitors are allowed to post messages


Name:
Email:
Notify me when I get a reply to my message:Yes  No

Icons:            

          

Subject:
Message:
 



Home | Forums | Members | Pictures | Contact Us

This site is in no way affiliated with Chrysler or any of its subsidiaries.