Dodge Dakota ForumDodge Dakota PhotosDodgeDakota.net Membership
  Forums   Forum Tools
04:54:04 - 12/21/2014

V6 Dakotas
FromMessage
Prairie Dak
Dodge Dakota
JOIN HERE
 Email

1/25/2002
21:36:34

Subject: Problems with 89 TBI...
IP: Logged

Message:
I recently picked up an '89 3.9L Dak 4x4 5 speed with 200k km on it, and it appears to have a few problems, so any help would be greatly appreciated.
1. when pulling the fault codes, a #12 always comes up. Where does the ECM pick up power for the backup? (FYI: The interior lights do not work, I suspect a bad fusible link).
2. Ran great for about a week, but then monday, the idle went through the roof!! Idle actually speeds up as the engine warms up!! At operating temp, it screams along at 3000!! Where to start, TPS or idle kicker? See #1. Is this a common prob??
3. 4x4 light stays on in the cab, obviously the front dif is staying locked up. Where to start with trying to repair??
4. Brake light stays on in dash. Just did the brakes and bled tons of air. Can the switch be reset??

Thanks for and all help. Gotta get this thing going soon. Getting 6-8 inches of snow tonight!!

Brian from Calgary



TigerDak
Dodge Dakota
JOIN HERE


1/27/2002
00:31:06

RE: Problems with 89 TBI...
IP: Logged

Message:
I own the exact same truck.

1. Disregard fault codes 12, 33, and 55

2. I think there is a sensor problem with your idle speed. Do another fault code check.

3. Its probably not the front diff that is causing the 4x4 to stay on. There is a 4x4 shifter that is probably getting stuck. Its located near the front diff, a small, shiny round thing. It may not be responding to the cab's shifter. Or, the 4x4 indicator sensor may not be working, and thinks its still in 4x4 when its really not. Thats a tough one.

4. My brake light has stayed on since last summer when I replaced the front an rear brakes. I was told the parking brake wire is frozen, and I havent gotten around to fixing it. So the brake light thinks its still engaged or there is a problem. Check your parking brake.



Prairie Dak
Dodge Dakota
JOIN HERE


1/27/2002
20:45:06

RE: Problems with 89 TBI...
IP: Logged

Message:
Thanks for the info, as soon as it warms up again I'll have another look (I've got another vehicle).

I am a little concerned about the #12 fault code. That's loss of backup power to the ECM, and thusly no codes could heald in memory.

I'll let you know what I can come up with.

Brian



Spyder343
Dodge Dakota
JOIN HERE
 Email

1/28/2002
03:12:40

RE: Problems with 89 TBI...
IP: Logged

Message:
Hi Brian. I had the same problem with my 4 wheel drive light. Here is a link to the directions to fix it:
http://www.walt-n-ingrid.com/modifications.html

With mine, I actually had to pull the entire Central Axle Disconnect and clean it, and it had some rust holes on the vacuum canister that I had to fill, but this is the best way to troubleshoot the system. Be sure to check all the vacuum lines for wear or leakage, especially where it goes under the oil filter.

As for the idle speed problem, I would look into replacing the Idle Speed Control motor. It has an error code, 25, and will illuminate the check engine light if tripped. The "12" error code simply means that there have been no codes in the last fifty "Key on" cycles. One thing you may want to do to check if your PCM is losing power is to look for error code "33" (Open or short condition in the A/C circuit) if you have no A/C, or "34" if you have no cruise control (Open or shorted condition in speed control solonoid circuit). These codes should always appear if you have no A/C or Cruise Control. If they are not, you may have a PCM Power problem. Hope this helps!



Prairie Dak
Dodge Dakota
JOIN HERE


1/28/2002
12:06:34

RE: Problems with 89 TBI...
IP: Logged

Message:
Thanks Guys!!

As soon as it warms up a bit (-30C last night, the Honda almost didn't go this AM) I'll have a better look at it.

As for the Idle kicker motor, I can here it moving when the key is operated, so I don't think that it is seized. Could the TPS be causing this?? Or possibly a temperature sender?? It is really bizzare because the idle will actually increase as the engine warms up!!

As for the front diff, I suspected it was that vacuum motor, but I've only had it a couple of weeks, and without a heated garage, it just sits in the back alley covered in snow!!



t man
Dodge Dakota
JOIN HERE


1/28/2004
20:53:26

RE: Problems with 89 TBI...
IP: Logged

Message:
i have an 89 dakota having problems when i drive a ways it stalls then when i restart it speeds way up and stalls again . check engine lite comes on . it is code 34 how do i go about fixing the problem thank you.



Dianes 88 Dak
GenI
 Email User Profile


1/29/2004
13:45:26

RE: Problems with 89 TBI...
IP: Logged

Message:
Prairie Dak
I just had almost every problem you are discribing, on my 88, hope this helps a little at least.

1. when pulling the fault codes, a #12 always comes up. Where does the ECM pick up power for the backup? (FYI: The interior lights do not work, I suspect a bad fusible link).

On my 88, 12 simply means the battery has been disconected, in the last so many key strokes which resets the comp. and mine only had one episode the first week I had it, so I figured they had cable off or unplugged the ecm which resets them.
Maybe your seller disconnected it for a bit hoping no codes would show up when anybody came to look at it.
No problem with my interior lights, but this could be your light switch or a wire from the EMR module also(more on EMR below)

2. Ran great for about a week, but then monday, the idle went through the roof!! Idle actually speeds up as the engine warms up!! At operating temp, it screams along at 3000!! Where to start, TPS or idle kicker? See #1. Is this a common prob??

Common prob, yes.
Does it idle back down without turning it off? Would you describe it more as irractic idleing?
I replaced the TPS on mine right away, along with other sensors and none of it helped just cleaned & adjusted ISC. The following week after I got it...I drove home from work one day 20 miles and didn't give it a drop of gas, cruised right at 65 the whole way too and a couple other times had to turn engine off twice when driving, RPMs going thru roof.

Mine ended up being the interuptor/reluctor in the distributor. When you pull the cap there's a black pick up that has to be removed to see the the interuptor, two screws. Mine was white plastice an had a lot of slop in it, side to side, etc. (This has been a very common prob)
I replaced the dist. Auto Zone $79.99/with old core or Advanced Auto(advanced will match Auto Zone price) and they come with new pick up in them, whereas my local mopar dealer said there's doesn't $96 + $34.).
I also replaced the O2 at the same time, which your truck most likely is due for.

That took care of the idle/RPM problem and mine also came to a point where it started dying when slowing or coming to a stop.
Runs & idles great now.

3. 4x4 light stays on in the cab, obviously the front dif is staying locked up. Where to start with trying to repair??

This may not be of any use to you...
Mine would stay on for a bit after using 4 WD, then go off when I would start driving a little ways. Does yours feel like it came out of 4 WD?

I don't know if yours would be the same problem on this or not, but on mine, the EMR module had some fuzed/melted wires going to it, and from there to fuze box a couple connectors and up/into steering column. First look under dash for any bad looking wires.
EMR is under & behind the dash left side and above fuze box. I had to remove the dash panel around/below the steering column then the left panal. Mine is a blue box that slides down over a metal tab sticking up.
I fixed wiring and it took care of several bugs I was having. The wires were melted and fuze to others causing shorts. When I finished I had to reset to button inside EMR by sticking a 6" piece of wire down a small hole on front of it to turn off check engine light that I then had after repairing wiring.



4. Brake light stays on in dash. Just did the brakes and bled tons of air. Can the switch be reset??

Mine does this too, but was a simple problem you have probably already checked.
My e.brake doesn't work and it you just hit a bump or bump it with your foot, it moves the peddle just enough the light pops on. I fixed this by putting a small Tack in my truck cause I hated not being able to see the RPM's. Anyway, I installed it by the brake release and it hold it in place now, so even if I hit a bump or bump it the release can't move/turn on the light, etc. This probably is no help to you...LOL

Hope a least some of this has been of use to you.
Good Luck! Post back with results, etc.

Diane's 88 Dakota [MOPAR RULES...other's... well, you know]

vern
Dodge Dakota
JOIN HERE
 Email

1/29/2004
17:57:58

RE: Problems with 89 TBI...
IP: Logged

Message:
4x4 light on-right front[pass side] front housing
theres a round vaccuum canister hold on with four nuts,theres also two vaccuum lines remove these,with the truck running there should be vaccuum on one line,now shift in to 4wd there should be vaccuum on the other line and not on the first line,if you have this then the vaccuum canister diaphram may be broke and needs replacing.

if you don,t have vaccuum here then check lines for breaks/cracks and connections
[one line from motor to transfer case,one line from transfer to canister on frame,two lines from transfer to front housing,]you can remove the vaccuum motor on housing[4 nuts]pull off housing,reconnect two vaccuum lines,let motor hang
truck running shift from 2wd to 4wd to see if the shifting fork is moving on motor,this motor locks the front axles in for 4wd and out for 2wd and turns the 4wd light on in cab.


when you say int lights,are you talking about dash
or dome lights?dash lights-fuse,lights switch
dome light-fuse,light switch in door opening[push button and turn back and forth,bad contact]

idle-kicker motor,unplug and plug back in to see if its working or leave unplug so the idle stays down,TPS-should be able to unplug and idle stay down,replace as needed,

brake light on-put the toe of one shoe under the e. brake pedal holding out and pull the e. brake release handle,if the light goes out,adjust e.brake cable or wire the pedal up



BSAsteve
Dodge Dakota
JOIN HERE
 Email

1/29/2004
20:35:05

RE: Problems with 89 TBI...
IP: Logged

Message:
If you have a manual and a decent automotive vom i would strongly suggest that you check every sensor manualy. The ICS on my 88 did the same thing tryed adjusting it to no availl. so i just disconnected the darn thing and set my rpm via the plunger screw on the ics (note) do this adjustment with the engine warm the only problem is you will have to baby sit the engine when it's cold so she don't stall. Two other things you can try one is get an ics out of the bone yard or just wire a damn choke cable to the throttle to keep it alive when it's cold. Next victim 4wd make sure that the wireing for you're indicator lamp doesn't have a dead short. If you look real close at the wiring on you're mopar you can see LUCAS stamped on it HAHAHAHAHAHA.



TC
Dodge Dakota
JOIN HERE
 Email

3/30/2005
19:00:28

RE: Problems with 89 TBI...
IP: Logged

Message:
Is there anywhere on the internet that you can get a wiring chart on a 98 Dodge Dakota?? I have one that at times will just stop while driving. I know there is a short somewhere and it seems to have maybe been rewired somewhere thru time.



CombatMedic
Dodge Dakota
JOIN HERE
 Email

10/15/2005
00:27:21

RE: Problems with 89 TBI...
IP: Logged

Message:
I had the same idle problem with my 89 dak. The previous owner had done some serious fording and the computer in the engine compartment on the passenger side was nasty with water and dirt. i bought a new one from rockauto.com for about $140 or something near that. more with shipping. plugged it up and it ran like it was right off the showroom floor. hope that helps.



andrew doughe
Dodge Dakota
JOIN HERE
 Email

5/07/2006
14:34:37

RE: Problems with 89 TBI...
IP: Logged

Message:
I just bought a 1989 v6 3.9 dodge dakota and it's horrible on gas, i mean horrible not to mention it has no power goin up a hill. i get about 20 miles to 1/4 of a tank could ne one give me some suggestions on why it might be so bad. I thought that it might be stuck in 4x4 but it's not i had it on the lift and you can hold the front tires and they dont spin. Im completely baffeled on whya 6 cyclinder would be so bad on gas ne suggetions would help



me
Dodge Dakota
JOIN HERE


5/07/2006
15:57:51

RE: Problems with 89 TBI...
IP: Logged

Message:
Because it's a 4X4 with a 125 HP engine!!!



vern
Dodge Dakota
JOIN HERE
 Email

5/08/2006
05:54:42

RE: Problems with 89 TBI...
IP: Logged

Message:
1 run the codes and see what comes up

2 check the timing

3 O2 sensor and/or the map play a big role in the mpg,check these out

4 do a good tune up,plugs,wires,dist cap and rotor,air filter

5 plugged cat convertor,

6 a bad temp sensor for the pcm,may be telling the pcm the engine is,nt up to temp

any of these will cause poor power and mpg

these early premag 3.9s are not the most powerful motors but with a little tuning and a few mods they will run with the stock mag,you should get 15-19mpg with a 4x4 depending on how you drive



matt
Dodge Dakota
JOIN HERE
 Email

4/18/2007
00:48:35

RE: Problems with 89 TBI...
IP: Logged

Message:
any help would be great have an 88 dakota v6 idle's great when you put it in gear and go down the road it stubles on it's face no power. when you hit the throttle it dies or just bogs down any idea's. changed the 02, iac motor, tps and fuel pressure regulater



b wallace
Dodge Dakota
JOIN HERE
 Email

10/15/2007
09:43:13

RE: Problems with 89 TBI...
IP: Logged

Message:
i have a 1989 3.9 that dies at stops signs. the idle did drop to 150 rpm.s when you put the brakes on . the engine will die every time at stop signs now . get in and start engine before taking off and engine idles at 650. idle problem is when you drive the truck.runs ruff all the time .can someone help,thanks



jason larmay
Dodge Dakota
JOIN HERE
 Email

1/07/2008
02:01:56

RE: Problems with 89 TBI...
IP: Logged

Message:
i have 89 dodge dakota tbi 4 cyl ihave no fuel past fuel presser regulater new part? computer s new checkers auto new injector also



jack
Dodge Dakota
JOIN HERE
 Email

3/23/2010
13:39:32

RE: Problems with 89 TBI...
IP: Logged

Message:
i have a 89 dakota, 2wd v6
i cant find where the oil transfer unit plugs into the head, any ideas?
maybe a diagram?



brad allison
Dodge Dakota
JOIN HERE
 Email

3/24/2010
14:23:45

RE: Problems with 89 TBI...
IP: Logged

Message:
i got a 89 dodge dakota 4x4 i changed the computer coil pick coil dist cap rotor and i am getting no spark from the coil and i am getting no gas in the carb eacher can anybody help



clarkj
Dodge Dakota
JOIN HERE
 Email

4/03/2010
18:16:21

RE: Problems with 89 TBI...
IP: Logged

Message:
i have an 89 dakota. it chuggs at a steady speen but not if i let off the gas or speed up. i've checked the codes and i get 24 and 27. both relating to the TPS and the idle control unit. what should i do? i believe i got a batch of bad gas but i think its more than that.



patricktaylor
Dodge Dakota
JOIN HERE
 Email

6/15/2010
22:17:11

RE: Problems with 89 TBI...
IP: Logged

Message:
what is tbi on a 1989 dodge dakota my engine just stops running signal lights don't work dash lights just blink on and off could this problem be with my ecm thanks



   P 1 Next Page>>


 



Home | Forums | Members | Pictures | Contact Us

This site is in no way affiliated with Chrysler or any of its subsidiaries.